use strict;
my $str = 'January 15, 2018
January 15,2018
January15, 2018
January15,2018
January 15 2018
Feb 15, 2018';
my $regex = qr/^([A-Za-z]+)(\s*)([0,1]*[0-9])(,*\s*)([0-9]{2,4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}