$re = '/(\R{2})\R+/u';
$str = 'Dummy text
some more text
and
Dummy text
some more text';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;