#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z'.]+(?: [a-zA-Z']+)*"
Local $sString = "John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson" & @CRLF & _
"John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson" & @CRLF & _
"John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson" & @CRLF & _
"Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler" & @CRLF & _
"Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler" & @CRLF & _
"Drama, Sci Fi, TV Show, Action" & @CRLF & _
"Drama, Action, HORROR, Adventure" & @CRLF & _
"Thriller, Mystery, Comedy" & @CRLF & _
"Comedy Romance, Action Comedy, CRIME, Sci Fi" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")