using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^\s]+).*?id=""opensource"".*?>(?:\s+)?(.+?)(?:\s+)?<\/\1>";
string input = @" <article id=""opensource"">Cabby </article>
<article id=""opensource"">
Cabby
</article>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}