import Foundation
let pattern = ##"""
^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"-0000100000.011100000000000000001000000000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}