import Foundation
let pattern = #"(?:(?:(public|protected|private)\s+)|(?:(abstract|static)\s+)|(?:(final)\s+)|(?:(volatile|synchronized)\s+)|(?:(native|strictfp)\s+))*([a-zA-Z_][[:alnum:]]+)\s+([a-zA-Z_][[:word:]<>\[\]]+)\s*\(\s*(?:(?:([a-zA-Z_][[:word:]<>\[\]]+)\s+([a-zA-Z_][[:alnum:]]+)\s*)(?:,\s*([a-zA-Z_][[:word:]<>\[\]]+)\s+([a-zA-Z_][[:alnum:]]+)\s*)*)?\)\s*\{"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cat
cut
cot
c@t$
c?t
c t?
caut.
caat
cuut!
hello
hello world
lite.ral $ sign
lit\erbl ^ car[a]t
Robert
Bob
Rob
Rick
Rick
lo
lol
loll
lolll
lollll
lolllll
lollllll
lolllllll
lollllllll
lolllllllll
lollllllllll
lolllllllllll
lollllllllllll
while (a < b) { while (c < d) { --d;}; while (b < c) { ++a; --c; } }
10001
18052
19146
<b>thing</a>
+1 555-234-1234 == matches
(654) 999-0234 == matches
+1 (101) 234 9838 == matches
333 444.5555 == matches
111.234-3463 == matches
+1-333-333-3333 == doesn't match (drops the +1)
555 2341234 == doesn't match (missing a separator)
231-1115 == doesn't match (missing an area code)
doowopdoo
shoobeedoobee
doodoodoo
doowop
0
C
a@b.c
bob@bob.bob
steve@steve.co.uk
tom.jones@its.not.unusual
0.0
+.03
-100.3
4.5e5
+0.03e-9
.01e12
.e4
-.e
public static void main(String[] args) {
return;
}
private double thingDoer (int thingA , float thingB) {
while (thingA < thingB) { ++thingA; }
return thingA * thingB;
}
boolean blobber(){
// do blob things
return false;
}
invalidMethodSignature here{
return;
}
anotherInvalidOne(){ return; }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)