$re = '/(?<day>\d+)\/(?<month>\d+)\/(?<year>\d+)/m';
$str = '16/04/1987
1/1/2021
31/1/2011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);