using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=((,.*){3})$)";
string substitution = @"$1";
string input = @"V1, V2, V3, V4, V5, V6, V7, V8, V9, V10";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}