import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MyFunction(\\((?>\\((?<c>)|[^()]+|\\)(?<-c>))*(?(c)(?!))\\))";
final String string = "MyFunction(23)\n"
+ "MyFunction('Sekret')\n"
+ "MyFunction( 23, 'Sekret', Date() )\n"
+ "MyFunction( Encrypt('Sekret'), Date() )\n"
+ "logger.info(\"MyFunction( Encrypt('Sekret'), Date() )\") \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}