re = /\A(?=[a-z0-9@.!#$%&'*+\/=?^_`{|}~-]{6,254}\z)
(?=[a-z0-9.!#$%&'*+\/=?^_`{|}~-]{1,64}@)
[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*
@ (?:(?=[a-z0-9-]{1,63}\.)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+
(?=[a-z0-9-]{1,63}\z)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\z/m
str = 'ragedog@hotmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end