#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\{ queryRunner \}, ([\n{}A-Za-z0-9., :]*)\{\n*\s*user,*(: [a-zA-Z,]+)?\n*\s*\} as ContextWithUser"
Local $sString = "const updatedEvent2 = await Resolver.updateEvent(" & @CRLF & _
" { queryRunner }, " & @CRLF & _
" { ...updatedEvent1 }, " & @CRLF & _
" { user: host } as ContextWithUser, " & @CRLF & _
" null" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"const updatedEvent2 = await Resolver.updateEvent({ queryRunner }, { ...updatedEvent1 }, { user } as ContextWithUser, null);" & @CRLF & _
"" & @CRLF & _
"await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.yes }, { user } as ContextWithUser);" & @CRLF & _
"" & @CRLF & _
"const updatedEventResponse = await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.no }, {" & @CRLF & _
" user: host," & @CRLF & _
" } as ContextWithUser);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")