use strict;
my $str = 'const updatedEvent2 = await Resolver.updateEvent(
{ queryRunner },
{ ...updatedEvent1 },
{ user: host } as ContextWithUser,
null
);
const updatedEvent2 = await Resolver.updateEvent({ queryRunner }, { ...updatedEvent1 }, { user } as ContextWithUser, null);
await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.yes }, { user } as ContextWithUser);
const updatedEventResponse = await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.no }, {
user: host,
} as ContextWithUser);';
my $regex = qr/\{ queryRunner \}, ([\n{}A-Za-z0-9., :]*)\{\n*\s*user,*(: [a-zA-Z,]+)?\n*\s*\} as ContextWithUser/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}