re = /\{ queryRunner \}, ([\n{}A-Za-z0-9., :]*)\{\n*\s*user,*(: [a-zA-Z,]+)?\n*\s*\} as ContextWithUser/m
str = 'const updatedEvent2 = await Resolver.updateEvent(
{ queryRunner },
{ ...updatedEvent1 },
{ user: host } as ContextWithUser,
null
);
const updatedEvent2 = await Resolver.updateEvent({ queryRunner }, { ...updatedEvent1 }, { user } as ContextWithUser, null);
await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.yes }, { user } as ContextWithUser);
const updatedEventResponse = await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.no }, {
user: host,
} as ContextWithUser);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end