// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\{ queryRunner \}, ([\n{}A-Za-z0-9., :]*)\{\n*\s*user,*(: [a-zA-Z,]+)?\n*\s*\} as ContextWithUser").unwrap();
let string = "const updatedEvent2 = await Resolver.updateEvent(
{ queryRunner },
{ ...updatedEvent1 },
{ user: host } as ContextWithUser,
null
);
const updatedEvent2 = await Resolver.updateEvent({ queryRunner }, { ...updatedEvent1 }, { user } as ContextWithUser, null);
await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.yes }, { user } as ContextWithUser);
const updatedEventResponse = await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.no }, {
user: host,
} as ContextWithUser);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}