^start of string
\s*any whitespace character, repeated any number of times
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s+any whitespace character, repeated at least once
\S+any non-whitespace character, repeated at least once
\s*any whitespace character, repeated any number of times
$end of string