$re = '/^\Qcustom_\E.+\d\Q.pid\E/m';
$str = 'custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);