package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(SMTP|IMAP):\sInvalid\spassword\sfor\suser\s(?<username>.+?)\s.*?\sAttempt\sfrom\sIP\saddress\s(?<ipaddress>.+)\.`)
var str = `IMAP: Invalid password for user abc@xyz.bla. mailto:abc@xyz.bla. Attempt from IP address 186.xxx.xxx.xxx.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}