#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?= \d|\D+$|(?<!.*\D) )"
Local $sString = "SomeStreet 59A" & @CRLF & _
"Somestreet 59-65" & @CRLF & _
"6' SomeStreet 59" & @CRLF & _
"Somestreet 2.1" & @CRLF & _
"Somestreet 65 A/1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")