$re = '/(?= \d|\D+$|(?<!.*\D) )/m';
$str = 'SomeStreet 59A
Somestreet 59-65
6\' SomeStreet 59
Somestreet 2.1
Somestreet 65 A/1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);