package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:'|").*(?:'|")`)
var str = `The sentence is 'He said "Hello there"'
The sentence is "He said 'Hello there'"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}