// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:'|").*(?:'|")"#).unwrap();
let string = "The sentence is 'He said \"Hello there\"'
The sentence is \"He said 'Hello there'\"
My text \"can contain\" both single 'and double\"' quotes. The quotes \"can also be 'nested\" as you can see.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}