const regex = /Project\("(?<Guid1>\{[\w-]+\})"\)\s*=\s*"(?<ProjectName>[\w\.]+)",\s*"(?<Path>.+)"\s*,\s"(?<Guid2>\{[\w-]+\})"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Project\\("(?<Guid1>\\{[\\w-]+\\})"\\)\\s*=\\s*"(?<ProjectName>[\\w\\.]+)",\\s*"(?<Path>.+)"\\s*,\\s"(?<Guid2>\\{[\\w-]+\\})"', 'g')
const str = `Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Logger.Core", "..\\..\\Logger\\Development\\Logger.Core\\Logger.Core.csproj", "{07095870-CF46-45F4-8E84-8B3C586BBF44}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}