# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Project\(\"(?<Guid1>\{[\w-]+\})\"\)\s*=\s*\"(?<ProjectName>[\w\.]+)\",\s*\"(?<Path>.+)\"\s*,\s\"(?<Guid2>\{[\w-]+\})\""
test_str = "Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"Logger.Core\", \"..\\..\\Logger\\Development\\Logger.Core\\Logger.Core.csproj\", \"{07095870-CF46-45F4-8E84-8B3C586BBF44}\""
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.