package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]*\sFOR\s£[0-9]*`)
var str = `N1 LTPO BABY FOOD 6 FOR £5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}