const regex = /(?<=[\w ]\()([^;\n]|".*?")*(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\w ]\\()([^;\\n]|".*?")*(?=\\))', 'gm')
const str = `foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
bazbaz(") " d " ;" );
h(dsaqwd)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
foo(() ((hello) world)); bar(gffjdk)
f("a;");g("b");
f("a;\\"");g("b");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}