use strict;
my $str = 'foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
bazbaz(") " d " ;" );
h(dsaqwd)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
foo(() ((hello) world)); bar(gffjdk)
f("a;");g("b");
f("a;\\"");g("b");';
my $regex = qr/(?<=[\w ]\()([^;\n]|".*?")*(?=\))/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}