re = /(?<=[\w ]\()([^;\n]|".*?")*(?=\))/mx
str = 'foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
bazbaz(") " d " ;" );
h(dsaqwd)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
foo(() ((hello) world)); bar(gffjdk)
f("a;");g("b");
f("a;\\"");g("b");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end