package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+(?:\.[0-9]+)?`)
var str = `.....
50
50.12
1.1234
5894023253.1341223`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}