// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^((feature|bugfix)\/[A-Z]+-\d+)|^(release\/(R2\d)(-)\d{2}.\d.\d))([a-z-]+)?").unwrap();
let string = "feature/JIRA-123
bugfix/JIRA-123-fix
release/R21-07.3.0
release/R21-07.3.0-fix";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}