package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^4[0-9]{12}(?:[0-9]{3}){0,2}$`)
var str = `4111111111111111
4012888888881881
4222222222222
4222222222222881325`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}