#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w{4,}@+\w{2,}(.com|.co.uk)$"
Local $sString = "abcd@ef.com" & @CRLF & _
"1111@ef.com" & @CRLF & _
"a1cd@ef.com" & @CRLF & _
"abcd@1f.com" & @CRLF & _
"ab2d@e2.com" & @CRLF & _
"abcd@ef.co.uk" & @CRLF & _
"abcd@eF.co.uk" & @CRLF & _
"a1cd@ef.co.uk" & @CRLF & _
"abcd@1f.co.uk" & @CRLF & _
"ab2d@e2.co.uk" & @CRLF & _
"ab2d@DD.co.uk" & @CRLF & _
"ab2d@vv.co.eu" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")