import Foundation
let pattern = #"^\w{4,}@+\w{2,}(.com|.co.uk)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd@ef.com
1111@ef.com
a1cd@ef.com
abcd@1f.com
ab2d@e2.com
abcd@ef.co.uk
abcd@eF.co.uk
a1cd@ef.co.uk
abcd@1f.co.uk
ab2d@e2.co.uk
ab2d@DD.co.uk
ab2d@vv.co.eu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)