#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^_\n]*)_([^_\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\w+)(.*)"
Local $sString = "foo_bar_something-like_this-me" & @CRLF & _
"bar--foo_something-like_this-me--" & @CRLF & _
"something-like--bar--foo_this-me----" & @CRLF & _
"this-me------something-like--bar--foo--" & @CRLF & _
"--this-me------something--bar--foo----like" & @CRLF & _
"----this------something--bar--foo----like--me" & @CRLF & _
""
Local $sSubst = "$2--$1$3$4$6--$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)