import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^_\\n]*)_([^_\\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\\w+)(.*)";
final String string = "foo_bar_something-like_this-me\n"
+ "bar--foo_something-like_this-me--\n"
+ "something-like--bar--foo_this-me----\n"
+ "this-me------something-like--bar--foo--\n"
+ "--this-me------something--bar--foo----like\n"
+ "----this------something--bar--foo----like--me\n";
final String subst = "$2--$1$3$4$6--$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}