#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-F][+-]?|D"
Local $sString = "A+" & @CRLF & _
"A" & @CRLF & _
"B+" & @CRLF & _
"AAA" & @CRLF & _
"CCC" & @CRLF & _
"GG" & @CRLF & _
"D" & @CRLF & _
"XX" & @CRLF & _
"C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")