package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-F][+-]?|D`)
var str = `A+
A
B+
AAA
CCC
GG
D
XX
C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}