re = /(?:\/\?)|(?:artist=([^&]*))|(?:title=([^&]*))|(?:album=([^&]*))|(?:year=([^&]*))|(?:type=([^&]*))/m
str = '/?artist=MyArtist&title=MyTitle&album=TheBestOf&year=2019&type=Music
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end