import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(DBC-Pillar单)+";
final String string = "00013200607-DBC-Pillar单个气孔.csv\n"
+ "00013200607-DBC-Pillar总气孔.csv\n"
+ "00013200607-芯片-DBC单个气孔.csv\n"
+ "00013200607-芯片-DBC总气孔.csv\n"
+ "00013200607-芯片-Spacer单个气孔.csv\n"
+ "00013200607-芯片-Spacer总气孔.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}