// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(DBC-Pillar单)+").unwrap();
let string = "00013200607-DBC-Pillar单个气孔.csv
00013200607-DBC-Pillar总气孔.csv
00013200607-芯片-DBC单个气孔.csv
00013200607-芯片-DBC总气孔.csv
00013200607-芯片-Spacer单个气孔.csv
00013200607-芯片-Spacer总气孔.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}