# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))/,/g;t' <<< "403
123456
55324673 cups of tea and 1564 polar bears
ABC123131"