Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))
/
g
Input 1
1
New
403 123456 55324673 cups of tea and 1564 polar bears ABC123131
Substitution
,
403 123456 55324673 cups of tea and 1564 polar bears ABC123131