const regex = new RegExp('(?xm)
(?:\\s|^)
([-+]?(?:\\b\\d+\\.\\d*|\\.?\\d+)(?:[eE][-+]?\\d+)?)
(?=\\s|$)', 'g')
const str = `0.2 2.1 3.1 ab 3 c abc23
4534.34534345
.456456
1.
1e545
1.1e435ff
.1e232
1.e343
1231ggg
112E+12
4
5545ggg
dfgdf.5444
12312.1231
.1231
1231
1.wrr
1 34345 234 -121
177
-1e+ -1e+0 1e-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}