#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\d+x\d+\.\w+$).+$"
Local $sString = "100x100pass-this-string.jpg" & @CRLF & _
"and-pass-this.png" & @CRLF & _
"100x100.jpg-anyletters.jpg" & @CRLF & _
"" & @CRLF & _
"test-string-150x150.png" & @CRLF & _
"teststring.com-150x150.jpg" & @CRLF & _
"anyletters-100x100.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")