#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![.\d])\d+(?:\.\d+)+(?![.\d])"
Local $sString = "1.3.164.1.2583.15.46" & @CRLF & _
"546.598.856.1.68.268.695.5955565" & @CRLF & _
"x.yz1.3.164a.1" & @CRLF & _
".1.3.164.1" & @CRLF & _
"1.3.164.1." & @CRLF & _
"1.3.164..1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")