$re = '/dear\s+(mr|mrs|miss|ms)\b[^£]+(£[\d,.]+)(?:\D|\d(?![\d.]*%))+([\d.]+%)(?:\D|\d(?![\d.]*%))+([\d.]+%)/mi';
$str = '"Dear Mr case 1","the value of my property is £500,000.00 and it was built in 1980",
"The protected percentage is 13% for 2 years", "The interest rate is fixed for 2 years at 4.8%"
"Dear Mrs case 1","the value of my property is £40,000.93 and it was built in 1980",
"The protected percentage is 13.25% for 2 years", "The interest rate is fixed for 2 years at 4%"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);