package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"|\S+|\s+`)
var str = `[4,4] "This is fun"
2 2 +
#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}