#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\s(.*)\s(TITULAR|SUPLENTE)"
Local $sString = "YECOL Martin Sosa TITULAR" & @CRLF & _
"FAQ FACUNDO TORRES TITULAR" & @CRLF & _
"CURRY10 Luis Gonzalez TITULAR" & @CRLF & _
"BRAN Brandon Christian Suarez TITULAR" & @CRLF & _
"MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")