import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s(.*)\\s(TITULAR|SUPLENTE)";
final String string = "YECOL Martin Sosa TITULAR\n"
+ "FAQ FACUNDO TORRES TITULAR\n"
+ "CURRY10 Luis Gonzalez TITULAR\n"
+ "BRAN Brandon Christian Suarez TITULAR\n"
+ "MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}