re = /(\w+)\s(.*)\s(TITULAR|SUPLENTE)/m
str = 'YECOL Martin Sosa TITULAR
FAQ FACUNDO TORRES TITULAR
CURRY10 Luis Gonzalez TITULAR
BRAN Brandon Christian Suarez TITULAR
MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end