using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]+"":\s*""[^""]+""[,}]\s*(*SKIP)(*FAIL)|(?<![,:])""(?![:,]\s*[""}])";
string input = @"json_str = '''{""id"":""9"",""ctime"":""2018-02-13"",""content"":""abcd: ""efg."",""hots"":""103b"",""date_sms"":""2017-11-22""}'''";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}